Erro no certificado do console no servidor Linux da Kaspersky

Failed to connect to KSCL via the Web Console: Error Authentication service unavailable

Issue

Failed to connect to KSCL via the Web Console. The “Authentication service unavailable” error occurs.

Cause

There are several possible causes:

  • The DNS name of the Identity and Access Manager server specified when updating the application does not match the value of the iamHost parameter in the /etc/ksc-web-console-setup.json file.
  • The service kliam_srv.service is stopped.

Solution

  1. Compare the DNS name of the Identity and Access Manager server with the iamHost parameter in the /etc/ksc-web-console-setup.json file. If they don’t match, modify the iamHost parameter and save the changes.
  2. Make sure that kliam_srv.service is running. If it’s not, run it.

If the issue persists, collect the diagnostic data to submit a request to Kaspersky Technical Support:

  • Trace files for KSCL and the Web Console
  • HAR logs of the browser in use
  • Report collected with the collect.sh script
  • Archive with the files from /var/opt/kaspersky/klnagent_srv/iam
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Failed to connect to KSCL via the Web Console: Error Administration Server uses an untrusted certificate

Issue

Failed to connect to KSCL via the Web Console. The “Administration Server uses an untrusted certificate” error occurs.

Cause

The FQDN value (of the Identity and Access Manager server) specified when updating the application does not match with the Subject Alternative Names parameter in the KSCL certificate: /var/opt/kaspersky/klnagent_srv/1093/cert/klserver.cer.

Solution

  1. Open the /var/opt/kaspersky/klnagent_srv/iam/iam_config.yaml file in any editor.
  2. Find the ksc_address line. If it's missing from the file, add it after the iam_address line.
  3. For the ksc_address value, specify the Subject Alternative Names value from the KSCL certificate (/var/opt/kaspersky/klnagent_srv/1093/cert/klserver.cer) and save the changes.
  4. Make sure that the iamHost value in /etc/ksc-web-console-setup.json matches the iam_address value in the IAM component configuration. To find this address, run the following command:

    grep "iam_address:" /var/opt/kaspersky/klnagent_srv/iam/iam_config.yaml

  5. Restart the KSCL service on the device with Web Console.
  6. Reinstall the Web Console.

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